[Mondrian] CurrentDateMember

Timothy Jones Timothy.Jones at syniverse.com
Thu Oct 2 08:48:22 EDT 2008

Hi, Julian... 
I just subscribed to this list, hoping to catch these kinds of great
tips.   I didn't expect them so fast though!  GREAT WORK!
My history with OLAP so far is that I got the JPivot/Mondrian example at
http://liris.cnrs.fr/~sbimonte/view.pdf working under Eclipse/Tomcat,
and I started adding new Mondrian schemas and new databases within this
app (2 so far, with probably 10-12 more on the horizon).  I can't say
there were no struggles, because there were multiple
new-things-to-learn, but I was able to quickly prove that these two
tools can accomplish what I needed, and now my app continues to grow.

My heartfelt thanks to everyone who has given of themselves to create a
fantastic product that lets me impress my new boss (with relative ease).
I hope to be able to contribute back someday soon!

From: mondrian-bounces at pentaho.org [mailto:mondrian-bounces at pentaho.org]
On Behalf Of Julian Hyde
Sent: Wednesday, October 01, 2008 7:53 PM
To: 'Mondrian developer mailing list'
Subject: RE: [Mondrian] CurrentDateMember

I think the example had extra '\'s because it was taken from Java code
(inside java strings, " and \ need to be escaped). That's why it worked
for you to change '\\.' to '\.'.
If you had changed '\"Time\"' to '"Time"' it would probably have worked
too. It worked without Time because dimension names are optional -
although I recommend using dimension names, because it makes your code
clearer and reduces the amount of searching mondrian has to do.
I also see that you changed MMM to mmm. I'm guessing that in your
dimension months look like 'jan' rather than 'JAN'.
Thanks for letting us know what works.


	From: mondrian-bounces at pentaho.org
[mailto:mondrian-bounces at pentaho.org] On Behalf Of Shaffner Joshua
	Sent: Wednesday, October 01, 2008 3:29 PM
	To: Mondrian developer mailing list
	Subject: Re: [Mondrian] CurrentDateMember
	Finally got this working..
	Interesting that it works without [\"Time\"]?
	CurrentDateMember([Time], '[yyyy]\.[mmm]').Lag(12) :
	CurrentDateMember([Time], '[yyyy]\.[mmm]')
	On 10/1/08 6:16 PM, "Joshua Shaffner"
<joshua.shaffner at goodwill.org> wrote:

		Per a couple suggestions in IRC as well as Julian's blog
l), I tried the query below but to no luck. I either get no results or
internal error. If you see something, let me know. I am stumped...after
trying this and that for a couple hours over just a couple of lines.
		SELECT NON EMPTY {[Measures].[Retail Store Sales],
<truncated>} ON COLUMNS,
'[\"Time\"]\\.[yyyy]\\.[MMM]').Lag(12) :
		CurrentDateMember([Time], '[\"Time\"]\\.[yyyy]\\.[MMM]')
		from [MRSDS]
		where [Organization].[All Organizations].[<truncated>]
		PS: I have Time Hierarchy with two levels, year and

		Mondrian mailing list
		Mondrian at pentaho.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20081002/d7ab1bf2/attachment.html 

More information about the Mondrian mailing list