[Mondrian] Problem Using Dimension Twice

Matt Campbell mcampbell at pentaho.com
Tue May 5 08:26:31 EDT 2015


What version of Mondrian are you running?  And do you mean you've added two DimensionUsages based off the same source?  Just tried a simple crossjoin of 2 usages of the Time dim w/ Foodmart using Mondrian 3.9, that worked for me.


-----Original Message-----
From: mondrian-bounces at pentaho.org [mailto:mondrian-bounces at pentaho.org] On Behalf Of Isaias Sanchez
Sent: Tuesday, May 05, 2015 6:25 AM
To: Mondrian ML
Subject: [Mondrian] Problem Using Dimension Twice

Hi,

When I use a dimension twice (or more) in a cube, I can display one of them in rows and another in column, but I can't display both dimension together in Row field.

I get this exception:
Caused by: mondrian.olap.MondrianException: Mondrian Error:Tuple contains more than one member of hierarchy ...

I am just arriving to the list so probably you have talked about that before.

Cheers,

Isaias S.
_______________________________________________
Mondrian mailing list
Mondrian at pentaho.org
http://lists.pentaho.org/mailman/listinfo/mondrian


More information about the Mondrian mailing list