[Mondrian] Removing support for Java 5 & 6 (JDBC 3 and 4.0)

Tom Barber tom at analytical-labs.com
Wed Jun 17 13:56:36 EDT 2015


As you can't run the bi server on java 8 I wouldn't stop that yet!  ;)

I still hear of people on java 6 often but I've not compiled saiku for java
6 in a couple of years so it doesn't bother me.

Tom
On 17 Jun 2015 18:48, "Julian Hyde" <julianhyde at gmail.com> wrote:

> JDK 1.7 was EOLed on May 1st [1]. So it’s an old JDK too.
>
> No objections from me for dropping 1.5 and 1.6 support. I don’t mind
> dropping 1.7, either, but I suspect there are some who might.
>
> Julian
>
> [1] https://www.java.com/en/download/faq/java_7.xml
>
> On Jun 17, 2015, at 10:40 AM, Luc Boudreau <lucboudreau at gmail.com> wrote:
>
> Hello,
>
> Mondrian is still compiled by Java 5 through 7. This was done in order to
> support JDBC specifications 3 and 4.0.
>
> We'd like some feedback on the potential impact on the community if we go
> ahead and remove support for these old versions of the JDKs. Is there
> anyone out there who still care about having Mondrian compatible with old
> JDKs?
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian
>
>
>
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20150617/2f1dff94/attachment-0001.html 


More information about the Mondrian mailing list