[Mondrian] Schema Problem I can't see

Isaias Sanchez isaias.sanchez.l at gmail.com
Thu Jul 23 08:46:27 EDT 2015


Hello,


I have two versions of same schema for Mondrian4, and both of then are 
having same issue. After a simple query they don't display anything on 
Saiku 3.3.

The MDX query is:

WITH
SET [~ROWS] AS
     {[Time].[Month by Hour].[Month].Members}
SELECT
NON EMPTY {[Measures].[Calls]} ON COLUMNS,
NON EMPTY [~ROWS] ON ROWS
FROM [Sender/Receiver Reports]


Also attaching part of database logs regarding this Schema and Query.

Seems that Mondrian is using first element of each dimension 
('2014-09-01' for Time, 'Afghanistan' for Country and 'AIRTEL' for 
Operator) and making a join with these data, and that join is not 
returning anything then It doesn't evaluate anything else.

Help me understand if something is wrong on the schema or how to solve 
this problem.

Thanks,

Isaias Sanchez
-------------- next part --------------
A non-text attachment was scrubbed...
Name: armsSchema.mondrian4.xml
Type: text/xml
Size: 10734 bytes
Desc: not available
Url : http://lists.pentaho.org/pipermail/mondrian/attachments/20150723/256e8633/attachment-0002.xml 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: armsSchema.mondrian4v2.xml
Type: text/xml
Size: 7388 bytes
Desc: not available
Url : http://lists.pentaho.org/pipermail/mondrian/attachments/20150723/256e8633/attachment-0003.xml 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: database_logs.log
Type: text/x-log
Size: 11829 bytes
Desc: not available
Url : http://lists.pentaho.org/pipermail/mondrian/attachments/20150723/256e8633/attachment-0001.bin 


More information about the Mondrian mailing list