[Mondrian] JDK 1.5 support / JMX

Luc Boudreau lucboudreau at gmail.com
Mon Sep 23 11:15:59 EDT 2013


Matt,

If we have the build system compile the JMX classes only against java 6+
(like we do with JDBC implementations) would that fix it? We'd have to add
the trigger code in UtilCompatible, with a dummy implementation that does
nothing in JDK 5 and lower.


On Mon, Sep 23, 2013 at 10:31 AM, Matt Campbell <mcampbell at pentaho.com>wrote:

> I recently made some minor changes in my local fork to expose the
> Mondrian monitoring metrics via JMX.  I expect this could be useful for
> administrators trying to keep tabs on the current state of their
> Mondrian instances.  The changes I made require a feature introduced in
> jdk1.6, however, so we won't be able to incorporate it until we stop
> supporting 1.5.
>
> So:  how many people are still using 1.5?  What are people's opinions on
> how long we should continue to support 1.5?
>
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20130923/1b7462ee/attachment.html 


More information about the Mondrian mailing list