[Mondrian] Conflicts between MDX Queries

Matt Campbell mcampbell at pentaho.com
Tue Jun 11 08:59:31 EDT 2013

There were some recently fixed bugs related to the datatype being incorrectly guessed in some cases and then mishandled during rollup, (e.g. MONDRIAN-1469, MONDRIAN-1432).  Definitely worth trying against the latest.

From: mondrian-bounces at pentaho.org [mailto:mondrian-bounces at pentaho.org] On Behalf Of Pedro Vale
Sent: Tuesday, June 11, 2013 6:23 AM
To: Mondrian developer mailing list
Subject: Re: [Mondrian] Conflicts between MDX Queries

Adding some more info, the issue we saw some months ago had to do with a query populating the segment cache with int values and the following query expecting to find double values for the same segments - but I think the error log was clear.

There's another issue filed by Cees van Kemenade (and recently solved by Curtis) that could be related - at least the symptoms look similar.

Kleyson, have you tried using the latest mondrian build ?


Pedro Vale
Webdetails Dev Lead


A 2013/06/10, às 18:40, Kleyson Rios escreveu:

Unfortunately I couldn't find the query that makes the another queries
to fail.

I have tried to eliminate one-by-one, but at the same time a query can
generate or not another to fail.

Looks be a relationship n-by-n between the queries where it is
impossible isolate the problem.

So I am using a workaround where is to run first the problematic queries.

If some modrian developer wish, i can share my dashboard and some data
to debug and try to figure out the problem.

As I said before, Pedro Vale from Webdetais told me that some time they
had the same problem.

If run A, B and C. C fail.
But If run C, A and B. No query fail.

Kleyson Rios.

Kleyson Rios
Gestor de TI
Coordenador de BI / Banco de Dados
Gerência de Tecnologia da Informação
Secretaria de Estado da Saúde de Goiás
(62) 3201-3707

Se não pode vencer pelo talento, vença pelo esforço. (Dave Weinbaum)

Em 07/06/2013 16:28, Kleyson Rios escreveu:

After you asked me those question, I've realized that the error happens
only when the cache is empty.

So, in the first run of the 17 query dashboard I can see the errors, in
the 2nd time it run with no errors.

I will try figure out which query or queries are causing the problematic
one to fail.


Mondrian mailing list
Mondrian at pentaho.org<mailto:Mondrian at pentaho.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20130611/6327891d/attachment.html 

More information about the Mondrian mailing list