[Mondrian] MonetDB: Mondrian Foodmart Loader, NUMERIC/DECIMAL, and MDX results

Brandon Jackson usbrandon at gmail.com
Thu Oct 25 15:19:29 EDT 2012


I was able to load MonetDB with foodmart using the foodmart loader.  I
noticed that when the tables were created some of the columns had the
NUMERIC data type.  Everything loaded correctly.  Any SQL queries that I
issued doing SUM etc through Squirrel and the relevant JDBC driver worked
fine.

Mondrian 3.X included with Suite 4.5 issues proper SQL against MonetDB, but
the measure results come back as 0 in every query I tried.

When I changed the data types to DOUBLE or FLOAT, Mondrian's queries
finally show correct results.

Where should I look to understand where this problem is entering the
picture?
I don't know why SquirrelSQL receives and shows a table of correct results,
while Mondrian does not.  So far, by process of elimination:

Not at fault:
JDBC Driver (because SquirrelSQL  uses it and gets correct results)
MonetDB (because direct queries work)

At fault:
Mondrian somewhere...

---
Is this a sound way to look at the problem?
Would running the test suite against MonetDB give sufficient information to
fix this problem?
Is a database dialect what prevents these kinds of issues?

If I can receive a little guidance where to check and what needs to be
done, maybe I can even trace into this issue.

Thanks,

Brandon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20121025/2d32577a/attachment.html 


More information about the Mondrian mailing list