[Mondrian] Mondrian Digest, Vol 72, Issue 7

Mayur Mohite mayur.mohite at vizury.com
Fri Nov 9 07:08:10 EST 2012


Hi,
I downloaded the latest version of ant(v1.8.4)
I did -
export ANT_HOME=~/VizuryDev/Mondrian/apache-ant-1.8.4
export JAVA_HOME=/usr/lib/jvm/jdk1.5.0_22
export JAVA_HOME_15=/usr/lib/jvm/jdk1.5.0_22
export JAVA_HOME_16=/usr/lib/jvm/java-1.6.0-openjdk-amd64
export JAVA_HOME_17=/usr/lib/jvm/java-1.7.0-openjdk-amd64

Then I did -
ant
and got the same error.


Next I tried giving the relative path of the ant binary -
 ../apache-ant-1.8.4/bin/ant

then it gave the error in the compileJDK15 target -

-
mayur at ubuntu:~/VizuryDev/Mondrian/mondrian$ ../apache-ant-1.8.4/bin/ant
Buildfile: /home/mayur/VizuryDev/Mondrian/mondrian/build.xml

version:

antcontrib.download-check:

antcontrib.download:

install-antcontrib:

ivy.download-check:

ivy.download:

install-ivy:
     [echo] Installing IVY...

resolve:
     [echo] symlink=true
[ivy:resolve] :: Ivy 2.1.0 - 20090925235825 :: http://ant.apache.org/ivy/ ::
[ivy:resolve] :: loading settings :: url =
file:/home/mayur/VizuryDev/Mondrian/mondrian/ivysettings.xml
[ivy:resolve] :: resolving dependencies ::
pentaho#mondrian-workbench;TRUNK-SNAPSHOT
[ivy:resolve]     confs: [default]
[ivy:resolve]     found commons-codec#commons-codec;1.2 in public
[ivy:resolve]     found commons-httpclient#commons-httpclient;3.0.1 in
public
[ivy:resolve]     found commons-logging#commons-logging;1.0.3 in public
[ivy:resolve]     found commons-lang#commons-lang;2.3 in public
[ivy:resolve]     found commons-io#commons-io;1.3.2 in public
[ivy:resolve]     found jaxen#jaxen;1.1.1 in public
[ivy:resolve]     found dom4j#dom4j;1.6.1 in public
[ivy:resolve]     found msv#xsdlib;20030807 in public
[ivy:resolve]     found msv#relaxngDatatype;20030807 in public
[ivy:resolve]     found pull-parser#pull-parser;2 in public
[ivy:resolve]     found xpp3#xpp3;1.1.3.3 in public
[ivy:resolve]     found stax#stax-api;1.0 in public
[ivy:resolve]     found xml-apis#xml-apis;1.3.02 in public
[ivy:resolve]     found jdom#jdom;1.0 in public
[ivy:resolve]     found xom#xom;1.0 in public
[ivy:resolve]     found xerces#xmlParserAPIs;2.6.2 in public
[ivy:resolve]     found xalan#xalan;2.6.0 in public
[ivy:resolve]     found com.ibm.icu#icu4j;2.6.1 in public
[ivy:resolve]     found junit#junit;4.0 in public
[ivy:resolve]     found
pentaho#pentaho-mondrianschemaworkbench-plugins;1.0.49156 in pentaho-mvn
[ivy:resolve]     found pentaho#pentaho-xul-core;3.3-SNAPSHOT in pentaho-ivy
[ivy:resolve]     found commons-beanutils#commons-beanutils;1.6 in public
[ivy:resolve]     found commons-collections#commons-collections;3.2 in
public
[ivy:resolve]     found commons-logging#commons-logging;1.0.4 in public
[ivy:resolve]     found org.codehaus.groovy#groovy-all;1.5.6 in public
[ivy:resolve]     found pentaho#pentaho-xul-swing;3.3-SNAPSHOT in
pentaho-ivy
[ivy:resolve]     found pentaho-kettle#kettle-core;4.4.0-SNAPSHOT in
pentaho-ivy
[ivy:resolve]     found xerces#xercesImpl;2.9.1 in public
[ivy:resolve]     found xml-apis#xml-apis;1.3.04 in public
[ivy:resolve]     found pentaho-kettle#kettle-db;4.4.0-SNAPSHOT in
pentaho-ivy
[ivy:resolve]     found xml-resolver#xml-resolver;1.2 in public
[ivy:resolve]     found pentaho-kettle#kettle-engine;4.4.0-SNAPSHOT in
pentaho-ivy
[ivy:resolve]     found pentaho-kettle#kettle-dbdialog;4.4.0-SNAPSHOT in
pentaho-ivy
[ivy:resolve]     found pentaho#pentaho-xul-core;3.3.4 in pentaho-ivy
[ivy:resolve]     found pentaho#pentaho-xul-swing;3.3.4 in pentaho-ivy
[ivy:resolve]     found pentaho#pentaho-xul-swt;3.3.4 in pentaho-ivy
[ivy:resolve]     found org.eclipse#jface;3.3.0-I20070606-0010 in public
[ivy:resolve]     found org.eclipse.core#commands;3.3.0-I20070605-0010 in
public
[ivy:resolve]     found org.eclipse.core#runtime;3.3.100-v20070530 in public
[ivy:resolve]     found org.eclipse.equinox#common;3.3.0-v20070426 in public
[ivy:resolve]     found log4j#log4j;1.2.8 in public
[ivy:resolve]     found commons-pool#commons-pool;1.3 in public
[ivy:resolve]     found commons-dbcp#commons-dbcp;1.2.1 in public
[ivy:resolve]     found commons-beanutils#commons-beanutils;1.8.0-BETA in
public
[ivy:resolve]     found commons-logging#commons-logging-api;1.1 in public
[ivy:resolve]     found commons-vfs#commons-vfs;1.0 in public
[ivy:resolve]     found org.eclipse.swt.win32.win32#x86;3.3.0-v3346 in
public
[ivy:resolve]     found pentaho#pentaho-application-launcher;1.0.2 in
pentaho-ivy
[ivy:resolve] :: resolution report :: resolve 28149ms :: artifacts dl 79ms
[ivy:resolve]     :: evicted modules:
[ivy:resolve]     junit#junit;3.8.1 by [junit#junit;4.0] in [default]
[ivy:resolve]     commons-logging#commons-logging;1.0.3 by
[commons-logging#commons-logging;1.0.4] in [default]
[ivy:resolve]     xml-apis#xml-apis;1.0.b2 by [xml-apis#xml-apis;1.3.02] in
[default]
[ivy:resolve]     jaxen#jaxen;1.1-beta-6 by [jaxen#jaxen;1.1.1] in [default]
[ivy:resolve]     xml-apis#xml-apis;1.3.02 by [xml-apis#xml-apis;1.3.04] in
[default]
[ivy:resolve]     xerces#xercesImpl;2.6.2 by [xerces#xercesImpl;2.9.1] in
[default]
[ivy:resolve]     xml-apis#xml-apis;2.0.2 by [xml-apis#xml-apis;1.3.02] in
[default]
[ivy:resolve]     pentaho#pentaho-xul-core;3.3-SNAPSHOT by
[pentaho#pentaho-xul-core;3.3.4] in [default]
[ivy:resolve]     commons-beanutils#commons-beanutils;1.6 by
[commons-beanutils#commons-beanutils;1.8.0-BETA] in [default]
[ivy:resolve]     commons-lang#commons-lang;2.2 by
[commons-lang#commons-lang;2.3] in [default]
[ivy:resolve]     jaxen#jaxen;1.1 by [jaxen#jaxen;1.1.1] in [default]
[ivy:resolve]     pentaho#pentaho-xul-swing;3.3-SNAPSHOT by
[pentaho#pentaho-xul-swing;3.3.4] in [default]
    ---------------------------------------------------------------------
    |                  |            modules            ||   artifacts   |
    |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
    ---------------------------------------------------------------------
    |      default     |   55  |   9   |   0   |   12  ||   55  |   0   |
    ---------------------------------------------------------------------
[ivy:retrieve] :: retrieving :: pentaho#mondrian-workbench
[ivy:retrieve]     confs: [default]
[ivy:retrieve]     0 artifacts copied, 42 already retrieved (0kB/34ms)
[ivy:retrieve] :: retrieving :: pentaho#mondrian-workbench
[ivy:retrieve]     confs: [default]
[ivy:retrieve]     0 artifacts copied, 13 already retrieved (0kB/27ms)
[ivy:resolve] :: resolving dependencies :: pentaho#mondrian;TRUNK-SNAPSHOT
[ivy:resolve]     confs: [codegen, default, default-jdk1.4, sources, dist,
test]
[ivy:resolve]     found commons-collections#commons-collections;3.2 in
public
[ivy:resolve]     found commons-dbcp#commons-dbcp;1.2.1 in public
[ivy:resolve]     found commons-pool#commons-pool;1.2 in public
[ivy:resolve]     found xerces#xerces;2.0.2 in public
[ivy:resolve]     found commons-lang#commons-lang;2.4 in public
[ivy:resolve]     found commons-io#commons-io;1.4 in public
[ivy:resolve]     found commons-logging#commons-logging;1.1.1 in public
[ivy:resolve]     found commons-math#commons-math;1.1 in public
[ivy:resolve]     found commons-vfs#commons-vfs;1.0 in public
[ivy:resolve]     found javacup#javacup;10k in pentaho-mvn
[ivy:resolve]     found net.java.dev.javacc#javacc;5.0 in public
[ivy:resolve]     found dom4j#dom4j;1.6.1 in public
[ivy:resolve]     found javax.validation#validation-api;1.0.0.GA in public
[ivy:resolve]     found eigenbase#eigenbase-xom;1.3.1 in pentaho-mvn
[ivy:resolve]     found xerces#xercesImpl;2.5.0 in public
[ivy:resolve]     found org.apache.ant#ant;1.7.1 in public
[ivy:resolve]     found org.apache.ant#ant-launcher;1.7.1 in public
[ivy:resolve]     found eigenbase#eigenbase-properties;1.1.2 in pentaho-mvn
[ivy:resolve]     found eigenbase#eigenbase-resgen;1.3.1 in pentaho-mvn
[ivy:resolve]     found sun#jlfgr;1.0 in pentaho-mvn
[ivy:resolve]     found javax.servlet#jsp-api;2.0 in public
[ivy:resolve]     found javax.servlet#servlet-api;2.4 in public
[ivy:resolve]     found log4j#log4j;1.2.14 in pentaho-mvn
[ivy:resolve]     found org.olap4j#olap4j;1.0.1.539 in pentaho-mvn
[ivy:resolve]     found xalan#xalan;2.4.1 in public
[ivy:resolve]     found
backport-util-concurrent#backport-util-concurrent;3.1 in public
[ivy:resolve]     found asm#asm;3.1 in public
[ivy:resolve]     found asm#asm-commons;3.1 in public
[ivy:resolve]     found asm#asm-tree;3.1 in public
[ivy:resolve]     found asm#asm-util;3.1 in public
[ivy:resolve]     found retroweaver#retroweaver;2.0.7 in pentaho-mvn
[ivy:resolve]     found retroweaver#retroweaver-rt;2.0.7 in pentaho-mvn
[ivy:resolve]     found org.apache.derby#derby;10.2.2.0 in public
[ivy:resolve]     found hsqldb#hsqldb;1.8.0.10 in public
[ivy:resolve]     found com.tonbeller#jpivot;1.8.0-100420 in pentaho-mvn
[ivy:resolve]     found org.olap4j#olap4j-tck;1.0.1.539 in pentaho-mvn
[ivy:resolve]     found org.olap4j#olap4j-xmla;1.0.1.539 in pentaho-mvn
[ivy:resolve]     found xerces#xercesImpl;2.6.0 in public
[ivy:resolve]     found junit#junit;3.8.1 in public
[ivy:resolve]     found xmlunit#xmlunit;1.1 in public
[ivy:resolve] :: resolution report :: resolve 4347ms :: artifacts dl 54ms
[ivy:resolve]     :: evicted modules:
[ivy:resolve]     commons-collections#commons-collections;2.1 by
[commons-collections#commons-collections;3.2] in [default]
[ivy:resolve]     xerces#xercesImpl;2.0.2 by [xerces#xercesImpl;2.5.0] in
[default]
[ivy:resolve]     commons-logging#commons-logging;1.0.3 by
[commons-logging#commons-logging;1.1.1] in [default]
[ivy:resolve]     commons-logging#commons-logging;1.0.4 by
[commons-logging#commons-logging;1.1.1] in [default]
    ---------------------------------------------------------------------
    |                  |            modules            ||   artifacts   |
    |       conf       | number| search|dwnlded|evicted|| number|dwnlded|
    ---------------------------------------------------------------------
    |      codegen     |   0   |   0   |   0   |   0   ||   0   |   0   |
    |      default     |   29  |   0   |   0   |   4   ||   24  |   0   |
    |  default-jdk1.4  |   7   |   0   |   0   |   0   ||   7   |   0   |
    |      sources     |   2   |   0   |   0   |   0   ||   2   |   0   |
    |       dist       |   3   |   0   |   0   |   0   ||   3   |   0   |
    |       test       |   7   |   2   |   0   |   0   ||   7   |   0   |
    ---------------------------------------------------------------------
[ivy:retrieve] :: retrieving :: pentaho#mondrian
[ivy:retrieve]     confs: [codegen, default, default-jdk1.4, sources, dist,
test]
[ivy:retrieve]     conflict on
/home/mayur/VizuryDev/Mondrian/mondrian/lib/xercesImpl.jar in [default,
test]: 2.6.0 won
[ivy:retrieve]     0 artifacts copied, 38 already retrieved (0kB/35ms)
[ivy:retrieve] :: retrieving :: pentaho#mondrian
[ivy:retrieve]     confs: [codegen, default, default-jdk1.4, sources, dist,
test]
[ivy:retrieve]     0 artifacts copied, 1 already retrieved (0kB/23ms)

prepare:

define-tasks:

parser:
  [javacup] Files are up to date.
   [javacc] Java Compiler Compiler Version 5.0 (Parser Generator)
   [javacc] (type "javacc" with no arguments for help)
   [javacc] Reading from file
/home/mayur/VizuryDev/Mondrian/mondrian/src/main/mondrian/parser/MdxParser.jj
. . .
   [javacc] Note: UNICODE_INPUT option is specified. Please make sure you
create the parser/lexer using a Reader with the correct character encoding.
   [javacc] File "TokenMgrError.java" is being rebuilt.
   [javacc] File "ParseException.java" is being rebuilt.
   [javacc] File "Token.java" is being rebuilt.
   [javacc] File "SimpleCharStream.java" is being rebuilt.
   [javacc] Parser generated successfully.

generate.resources:
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/src/main/mondrian/resource/MondrianResource.java
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/classes/mondrian/resource/MondrianResource.properties
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/src/main/mondrian/resource/MondrianResource_en_US.java
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/classes/mondrian/resource/MondrianResource_en_US.properties
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/src/main/mondrian/resource/MondrianResource_de_DE.java
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/classes/mondrian/resource/MondrianResource_de_DE.properties
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/src/main/mondrian/resource/MondrianResource_de.java
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/classes/mondrian/resource/MondrianResource_de.properties
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/src/main/mondrian/resource/MondrianResource_es_ES.java
is up to date
   [resgen]
/home/mayur/VizuryDev/Mondrian/mondrian/classes/mondrian/resource/MondrianResource_es_ES.properties
is up to date

generate.properties:
     [java] Generating src/main/mondrian/olap/MondrianProperties.java
     [java] Generating doc/properties.html
     [java] Generating mondrian.properties.template

def:

compileJdk15:
     [exec] Using JAVA_HOME: /usr/lib/jvm/jdk1.5.0_22
     [exec] Using Ant arguments: -Drequested.java.version=jdk1.5
-Dskip.download=true compile.java
     [exec] Buildfile: /home/mayur/VizuryDev/Mondrian/mondrian/build.xml
     [exec]
     [exec] BUILD FAILED
     [exec] java.lang.UnsupportedClassVersionError: Bad version number in
.class file
     [exec]     at java.lang.ClassLoader.defineClass1(Native Method)
     [exec]     at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
     [exec]     at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
     [exec]     at
java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
     [exec]     at
java.net.URLClassLoader.access$100(URLClassLoader.java:56)
     [exec]     at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
     [exec]     at java.security.AccessController.doPrivileged(Native
Method)
     [exec]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:188)
     [exec]     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
     [exec]     at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
     [exec]     at java.lang.ClassLoader.loadClass(ClassLoader.java:300)
     [exec]     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
     [exec]     at
javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:88)
     [exec]     at
javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:278)
     [exec]     at
javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:185)
     [exec]     at
javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:107)
     [exec]     at
org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java:120)
     [exec]     at
org.apache.tools.ant.util.JAXPUtils.getNSParserFactory(JAXPUtils.java:104)
     [exec]     at
org.apache.tools.ant.util.JAXPUtils.getNamespaceXMLReader(JAXPUtils.java:172)
     [exec]     at
org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:273)
     [exec]     at
org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:178)
     [exec]     at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:82)
     [exec]     at org.apache.tools.ant.Main.runBuild(Main.java:795)
     [exec]     at org.apache.tools.ant.Main.startAnt(Main.java:217)
     [exec]     at
org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
     [exec]     at
org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
     [exec]
     [exec] Total time: 0 seconds
     [exec] java.lang.UnsupportedClassVersionError: Bad version number in
.class file
     [exec]     at java.lang.ClassLoader.defineClass1(Native Method)
     [exec]     at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
     [exec]     at
java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
     [exec]     at
java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
     [exec]     at
java.net.URLClassLoader.access$100(URLClassLoader.java:56)
     [exec]     at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
     [exec]     at java.security.AccessController.doPrivileged(Native
Method)
     [exec]     at
java.net.URLClassLoader.findClass(URLClassLoader.java:188)
     [exec]     at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
     [exec]     at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
     [exec]     at java.lang.ClassLoader.loadClass(ClassLoader.java:300)
     [exec]     at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
     [exec]     at
javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:88)
     [exec]     at
javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:278)
     [exec]     at
javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:185)
     [exec]     at
javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:107)
     [exec]     at
org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java:120)
     [exec]     at
org.apache.tools.ant.util.JAXPUtils.getNSParserFactory(JAXPUtils.java:104)
     [exec]     at
org.apache.tools.ant.util.JAXPUtils.getNamespaceXMLReader(JAXPUtils.java:172)
     [exec]     at
org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:273)
     [exec]     at
org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:178)
     [exec]     at
org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:82)
     [exec]     at org.apache.tools.ant.Main.runBuild(Main.java:795)
     [exec]     at org.apache.tools.ant.Main.startAnt(Main.java:217)
     [exec]     at
org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
     [exec]     at
org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
     [exec] Bad version number in .class file

BUILD FAILED

-



Next I tried executing the compileJDK15 manually -
so I did -

mayur at ubuntu:~/VizuryDev/Mondrian/mondrian$ ../apache-ant-1.8.4/bin/ant
-Drequested.java.version=jdk1.5 -Dskip.download=true compile.java
Buildfile: /home/mayur/VizuryDev/Mondrian/mondrian/build.xml

apologise:

compile.java:
     [echo] Compiling on JVM Version: 1.5.0_22-b03
    [javac] Compiling 10 source files to
/home/mayur/VizuryDev/Mondrian/mondrian/classes
    [javac] Note: Some input files use or override a deprecated API.
    [javac] Note: Recompile with -Xlint:deprecation for details.
     [copy] Copying 1 file to
/home/mayur/VizuryDev/Mondrian/mondrian/classes

BUILD SUCCESSFUL
Total time: 4 seconds

And build succeeded.
Couldn't figure out though why is it throwing error when compiled via the
script.

-Mayur

On Thu, Nov 8, 2012 at 10:30 PM, <mondrian-request at pentaho.org> wrote:

> Send Mondrian mailing list submissions to
>         mondrian at pentaho.org
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         http://lists.pentaho.org/mailman/listinfo/mondrian
> or, via email, send a message with subject or body 'help' to
>         mondrian-request at pentaho.org
>
> You can reach the person managing the list at
>         mondrian-owner at pentaho.org
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Mondrian digest..."
>
>
> Today's Topics:
>
>    1. Re: Mondrian Digest, Vol 72, Issue 7 (Mayur Mohite)
>    2. Re: Mondrian Digest, Vol 72, Issue 7 (Julian Hyde)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Thu, 8 Nov 2012 09:52:29 +0530
> From: Mayur Mohite <mayur.mohite at vizury.com>
> Subject: Re: [Mondrian] Mondrian Digest, Vol 72, Issue 7
> To: <mondrian at pentaho.org>
> Message-ID:
>         <
> CAJ02O-ifZY6n6owjq2SxpAJFG8_tyK3CxSr_sDvFVsUTe-q3mw at mail.gmail.com>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Hi,
>
> I am using ant version 1.8.2.
> I am setting following environment variables -
>
> JAVA_HOME=/usr/lib/jvm/java1.5.0_15/
> JAVA_HOME_15=/usr/lib/jvm/java1.5.0_15/
> JAVA_HOME_16=/usr/lib/jvm/java-1.6.0-openjdk-amd64/
> JAVA_HOME_17=/usr/lib/jvm/java-1.7.0-openjdk-amd64/
>
> -Mayur
>
> On Wed, Nov 7, 2012 at 10:30 PM, <mondrian-request at pentaho.org> wrote:
>
> > Send Mondrian mailing list submissions to
> >         mondrian at pentaho.org
> >
> > To subscribe or unsubscribe via the World Wide Web, visit
> >         http://lists.pentaho.org/mailman/listinfo/mondrian
> > or, via email, send a message with subject or body 'help' to
> >         mondrian-request at pentaho.org
> >
> > You can reach the person managing the list at
> >         mondrian-owner at pentaho.org
> >
> > When replying, please edit your Subject line so it is more specific
> > than "Re: Contents of Mondrian digest..."
> >
> >
> > Today's Topics:
> >
> >    1. Re: Problem with building mondrian (Julian Hyde)
> >
> >
> > ----------------------------------------------------------------------
> >
> > Message: 1
> > Date: Wed, 7 Nov 2012 10:07:09 -0600
> > From: Julian Hyde <jhyde at pentaho.com>
> > Subject: Re: [Mondrian] Problem with building mondrian
> > To: Mondrian developer mailing list <mondrian at pentaho.org>
> > Message-ID: <A7A15582-2760-4769-9A75-1B9989F3AF8B at pentaho.com>
> > Content-Type: text/plain; charset="iso-8859-1"
> >
> > On Nov 6, 2012, at 9:28 PM, Mayur Mohite <mayur.mohite at vizury.com>
> wrote:
> >
> > > Hi,
> > >
> > > I tried to execute (with the same set of environment variables)-
> > > "ant clean"
> > > but I get following error messages-
> > >
> > > Buildfile: /home/mayur/VizuryDev/Mondrian/mondrian/build.xml
> > >
> > > BUILD FAILED
> > > java.lang.UnsupportedClassVersionError: Bad version number in .class
> file
> > >     at java.lang.ClassLoader.defineClass1(Native Method)
> > >     at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
> > >     at
> > java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
> > >     at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
> > >     at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
> > >     at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
> > >     at java.security.AccessController.doPrivileged(Native Method)
> > >     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> > >     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> > >     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
> > >     at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
> > >     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> > >     at
> javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:88)
> > >     at
> >
> javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:278)
> > >     at javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:185)
> > >     at
> > javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:107)
> > >     at
> > org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java:120)
> > >     at
> >
> org.apache.tools.ant.util.JAXPUtils.getNSParserFactory(JAXPUtils.java:104)
> > >     at
> >
> org.apache.tools.ant.util.JAXPUtils.getNamespaceXMLReader(JAXPUtils.java:172)
> > >     at
> > org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:273)
> > >     at
> > org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:178)
> > >     at
> >
> org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:82)
> > >     at org.apache.tools.ant.Main.runBuild(Main.java:793)
> > >     at org.apache.tools.ant.Main.startAnt(Main.java:217)
> > >     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
> > >     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
> > >
> > > Total time: 0 seconds
> > > java.lang.UnsupportedClassVersionError: Bad version number in .class
> file
> > >     at java.lang.ClassLoader.defineClass1(Native Method)
> > >     at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
> > >     at
> > java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
> > >     at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
> > >     at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
> > >     at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
> > >     at java.security.AccessController.doPrivileged(Native Method)
> > >     at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
> > >     at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> > >     at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
> > >     at java.lang.ClassLoader.loadClass(ClassLoader.java:299)
> > >     at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> > >     at
> javax.xml.parsers.FactoryFinder.newInstance(FactoryFinder.java:88)
> > >     at
> >
> javax.xml.parsers.FactoryFinder.findJarServiceProvider(FactoryFinder.java:278)
> > >     at javax.xml.parsers.FactoryFinder.find(FactoryFinder.java:185)
> > >     at
> > javax.xml.parsers.SAXParserFactory.newInstance(SAXParserFactory.java:107)
> > >     at
> > org.apache.tools.ant.util.JAXPUtils.newParserFactory(JAXPUtils.java:120)
> > >     at
> >
> org.apache.tools.ant.util.JAXPUtils.getNSParserFactory(JAXPUtils.java:104)
> > >     at
> >
> org.apache.tools.ant.util.JAXPUtils.getNamespaceXMLReader(JAXPUtils.java:172)
> > >     at
> > org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:273)
> > >     at
> > org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:178)
> > >     at
> >
> org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:82)
> > >     at org.apache.tools.ant.Main.runBuild(Main.java:793)
> > >     at org.apache.tools.ant.Main.startAnt(Main.java:217)
> > >     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:280)
> > >     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:109)
> > > Bad version number in .class file
> >
> > What version of ant are you using? Is your CLASSPATH environment variable
> > set?
> >
> > Julian
> >
> >
> >
> > ------------------------------
> >
> > _______________________________________________
> > Mondrian mailing list
> > Mondrian at pentaho.org
> > http://lists.pentaho.org/mailman/listinfo/mondrian
> >
> >
> > End of Mondrian Digest, Vol 72, Issue 7
> > ***************************************
> >
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
> http://lists.pentaho.org/pipermail/mondrian/attachments/20121108/105849ae/attachment-0001.html
>
> ------------------------------
>
> Message: 2
> Date: Thu, 8 Nov 2012 02:31:36 -0600
> From: Julian Hyde <jhyde at pentaho.com>
> Subject: Re: [Mondrian] Mondrian Digest, Vol 72, Issue 7
> To: Mondrian developer mailing list <mondrian at pentaho.org>
> Message-ID: <50103F03-3429-4595-AD13-0AA38FBBBCF9 at pentaho.com>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Your issue looks like this:
>
>
> http://ant.1045680.n5.nabble.com/XML-Parser-give-quot-bad-version-number-in-class-file-quot-td1355569.html
>
> In other words, it is something that ant relies on (namely, the XML
> parser), not anything inside Mondrian. At the end of that thread:
>
> > I installed the binary of the latest ant, and exported ANT_HOME to point
> to that directory.
>
> Give that a try.
>
> Julian
>
> ------------------------------
>
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian
>
>
> End of Mondrian Digest, Vol 72, Issue 8
> ***************************************
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20121109/f711ea6b/attachment-0001.html 


More information about the Mondrian mailing list