[Mondrian] HiveDialect not being found

Craig Soules craig at natero.com
Fri Jul 6 00:14:43 EDT 2012


Julian,

Thanks for the quick responses on this!

After I sent the last email I had tracked down that very if-else section
you describe, which was the actual source of my problem, so now it is using
the HiveDialect correctly.  I'm still having some problems with the loader
because Hive doesn't support specifying non-null columns in table creation,
but I think I can work things out from here.

I'll take a look at the changes you listed and see if either of them will
be of further use.

Thanks again!
Craig

On Thu, Jul 5, 2012 at 1:35 PM, Julian Hyde <jhyde at pentaho.com> wrote:

> Craig,
>
> I have made a couple of changes that should improve this. Currently on
> different branches.
>
> http://jira.pentaho.com/browse/MONDRIAN-789 on master branch (will go
> into release 3.4.x); not yet integrated into the lagunitas branch (which
> will be mondrian 4.0)
>
> http://jira.pentaho.com/browse/MONDRIAN-1182 on lagunitas branch (which
> will be mondrian 4.0). I do not intend to back-port this to 3.4.x.
>
> I don't know which version of Mondrian you are using, but both of these
> changes may be of help.
>
> Julian
>
>
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20120705/fd70626e/attachment.html 


More information about the Mondrian mailing list