[Mondrian] MONDRIAN-592

Julian Hyde jhyde at pentaho.com
Mon Jan 16 19:05:45 EST 2012


I'm not aware of a particular issue in that we fixed in 3.3.1 that would have fixed this.

The developers considered MONDRIAN-592 a duplicate of MONDRIAN-335, and that was fixed in change 10575. It would have been in mondrian-3.0.1. A long time ago.

Can you provide a test method that we could add to SteelWheelsTestCase that reproduces the problem. This is the safest way to ensure that it does not recur.

Julian


On Jan 16, 2012, at 12:54 PM, Kristopher Kiger wrote:

While validating queries return values today I ran across an issue that matched this case:

http://jira.pentaho.com/browse/MONDRIAN-592?page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#issue-tabs

I noted that the bug had been fixed and tried the associated steel wheels test given in the bug report.  It yielded the same result as explained in the bug.  I was able to reproduce it using schema workbench 3.3.0.14703.  I moved over to test this under saiku 2.2rc1, which appears to be using a snapshot of Mondrian 3.3.1.  The bug seems to be gone in that version.
Given that the resolution date of the original bug was set at 11/Aug/09, I felt it prudent to ask if the reoccurrence of it in 3.3.0 was a known issue and had been intentionally fixed in the 3.3.1 snapshot.  As usual, thanks for the help!
Cheers,
Kris



_______________________________________________
Mondrian mailing list
Mondrian at pentaho.org<mailto:Mondrian at pentaho.org>
http://lists.pentaho.org/mailman/listinfo/mondrian

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20120116/44b8c983/attachment.html 


More information about the Mondrian mailing list