[Mondrian] Numeric Member autoformat problem

mehdi b mehdi_xinu at yahoo.com
Wed May 11 06:35:58 EDT 2011


I'm using mondrian 3.2.1. I have a Level which is integer and it has 8 digits length, its definition is as follows:
<Dimention name="TrxDate">
<Hierarchy hasAll="true" allMemberName="All">
<Level name="TrxDate" column="..." uniqueMembers="true"/>

when I want to use this dimension in query like
SELECT {[Measures].{Trx]} on COLUMNS, {[TrxDate].[20110403]} on ROWS from [Types]

I encounter the error that [TrxDate].[20110403] not found, but when I run the query as
SELECT {[Measures].{Trx]} on COLUMNS, {[TrxDate].[2.0110403E7]} on ROWS from [Types]

the query executed successfully. I don't know how Mondrian formatted the members?
I also tried various types on the Level definition in schema like type="String" or type="Numeric" but the result is as the same. I also created a "MemberFormatter" and assigned it to the Level definition in schema, but it is not called.

I also tried the query
SELECT {[Measures].{Trx]} on COLUMNS, {[TrxDate]} on ROWS from [Types]

and then print the result through result.print() method and it seems that Mondrian load the members as scientific format.

I would appreciate any help!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20110511/a17bc3a8/attachment.html 

More information about the Mondrian mailing list