[Mondrian] FoodMart database

Julian Hyde jhyde at pentaho.com
Tue Dec 27 15:20:10 EST 2011

What JDK are you using?

Please post to mondrian at pentaho.org. Not to me personally, or to mondrian-devel at lists.sourceforge.net (that list is obsolete).


On Dec 25, 2011, at 8:01 AM, Gil Stelzer wrote:

> Hi All
> I downloaded the latest stable release of Mondrian (mondrian-
> I wanted to install the test data set called FoodMart on MySQL (linux) and followed the instructions carefully.
> I created the foodmart user with all permissions for the foodmart database.
> I intended to use MondrianFoodMartLoader to populate the database but when I used the following command
> java -cp "/mondrian/lib/mondrian.jar:/mondrian/lib/log4j.jar:/mondrian/lib/commons-logging.jar:/mondrian/lib/eigenbase-xom.jar:/mondrian/lib/eigenbase-resgen.jar:/mondrian/lib/eigenbase-properties.jar:/usr/local/mysql/mysql-connector-java-5.0.5-bin.jar"
>      mondrian.test.loader.MondrianFoodMartLoader
>      -verbose -tables -data -indexes
>      -jdbcDrivers=com.mysql.jdbc.Driver
>      -inputFile=/mondrian/demo/FoodMartCreateData.sql 
>      -outputJdbcURL="jdbc:mysql://localhost/foodmart?user=foodmart&password=foodmart"
> I received errors stating there were missing jar files.  I downloaded from the web the files missing from /mondrian/lib which were stated in the error message.  After MondrianFoodMartLoader  stopped complaining about missing jar files I received the following error message
> Exception in thread "main" java.lang.VerifyError: (class: mondrian/olap/Util, method: matches signature: (Lorg/olap4j/mdx/IdentifierSegment;Ljava/lang/String;)Z) Incompatible argument to function at mondrian.test.loader.MondrianFoodMartLoader.<clinit>(MondrianFoodMartLoader.java:100)
> Could not find the main class: mondrian.test.loader.MondrianFoodMartLoader. Program will exit.
> I also tried using jar files I found after exploding the mondrian.war file (log4j-1.2.8.jar ….) but this did NOT help.
> I saw that FoodMartCreateData.sql contains the insert statements for the FoodMart db, but no schema for it.  The FoodMart.xml seems to contain the schema but I cannot simply use it for creating tables without using MondrianFoodMartLoader, which simply doesn’t work.
> I also created a java project for Mondrian on eclipse and when I ran MondrianFoodMartLoader .java I received an error on line 100,
> java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/ThreadFactory
>      at mondrian.test.loader.MondrianFoodMartLoader.<clinit>(MondrianFoodMartLoader.java:100)
> Caused by: java.lang.ClassNotFoundException: edu.emory.mathcs.backport.java.util.concurrent.ThreadFactory
>      at java.net.URLClassLoader$1.run(Unknown Source)
>      at java.security.AccessController.doPrivileged(Native Method)
>      at java.net.URLClassLoader.findClass(Unknown Source)
>      at java.lang.ClassLoader.loadClass(Unknown Source)
>      at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
>      at java.lang.ClassLoader.loadClass(Unknown Source)
>      ... 1 more
> Exception in thread "main"
> Which is
> private static final String nl = Util.nl;
> It does not seem to be related to threading and clicking the link to line 100 results in an error message stating that 100 is not a valid line number in this file.
> I am really looking forward to seeing Mondrian system capabilities.
> Please help me in any way you can.  
> Thanks in advance.
> Gil

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20111227/10532975/attachment.html 

More information about the Mondrian mailing list