[Mondrian] CurrentDateMember

Shaffner Joshua joshua.shaffner at goodwill.org
Thu Oct 2 12:03:28 EDT 2008


In db, I have 1 thru 12 for months. Using jpivot w/o CurrentDateMember with
drilldown to month level would generate something like this: [Time].[All
Times].[2006].[May].

Per VB reference, http://www.apostate.com/vb-format-syntax, where it shows
MMM to display the month as abbrev (Jan ­ Dec), I tried MMM and got no
results. Using mmm however got me the results. It was an accident that I
typed in mmm and got the results. LoL.

Does it mean that the Mondarian is expecting mmm, not MMM?

As for using dimension names, I did try the following but it did not work
unless I remove dimension name.

No results pulled:
{(CurrentDateMember([Time], "['Time']\.[yyyy]\.[mmm]").Lag(13.0) :
CurrentDateMember([Time], "['Time']\.[yyyy]\.[mmm]").Lag(1.0))} ON ROWS

Results pulled:
{(CurrentDateMember([Time], "[yyyy]\.[mmm]").Lag(13.0) :
CurrentDateMember([Time], "[yyyy]\.[mmm]").Lag(1.0))} ON ROWS

PS: Am using biserver_ce 2.0.x

On 10/1/08 7:53 PM, "Julian Hyde" <jhyde at pentaho.com> wrote:

> I think the example had extra '\'s because it was taken from Java code (inside
> java strings, " and \ need to be escaped). That's why it worked for you to
> change '\\.' to '\.'.
>  
> If you had changed '\"Time\"' to '"Time"' it would probably have worked too.
> It worked without Time because dimension names are optional - although I
> recommend using dimension names, because it makes your code clearer and
> reduces the amount of searching mondrian has to do.
>  
> I also see that you changed MMM to mmm. I'm guessing that in your dimension
> months look like 'jan' rather than 'JAN'.
>  
> Thanks for letting us know what works.
>  
> Julian
> 
>>  
>>  
>> 
>>  From: mondrian-bounces at pentaho.org  [mailto:mondrian-bounces at pentaho.org] On
>> Behalf Of Shaffner  Joshua
>> Sent: Wednesday, October 01, 2008 3:29 PM
>> To:  Mondrian developer mailing list
>> Subject: Re: [Mondrian]  CurrentDateMember
>> 
>>  
>> Finally got this working..
>> 
>> Interesting that it  works without [\²Time\²]?
>> 
>> CurrentDateMember([Time],  '[yyyy]\.[mmm]').Lag(12) :
>> CurrentDateMember([Time],  '[yyyy]\.[mmm]')
>> 
>> 
>> On 10/1/08 6:16 PM, "Joshua Shaffner" <joshua.shaffner at goodwill.org>  wrote:
>> 
>>  
>>> Per a couple suggestions in IRC as well as Julian¹s  blog (
>>> http://julianhyde.blogspot.com/2006/10/mondrian-22-cube-designer-and.html),
>>> I tried the query below but to no luck. I either get no results or internal
>>> error. If you see something, let me know. I am stumped...after trying this
>>> and that for a couple hours over just a couple of lines.
>>> 
>>> SELECT NON  EMPTY {[Measures].[Retail Store Sales], <truncated>} ON
>>> COLUMNS,
>>> 
>>> NON EMPTY 
>>> {
>>> CurrentDateMember([Time],  '[\"Time\"]\\.[yyyy]\\.[MMM]').Lag(12) :
>>> CurrentDateMember([Time],  '[\"Time\"]\\.[yyyy]\\.[MMM]')
>>> }
>>> ON ROWS
>>> 
>>> from [MRSDS]
>>> where  [Organization].[All Organizations].[<truncated>]
>>> 
>>> 
>>> PS: I have  Time Hierarchy with two levels, year and month.
>>> 
>>>  
>>> 
>>>  _______________________________________________
>>> Mondrian  mailing list
>>> Mondrian at pentaho.org
>>> http://lists.pentaho.org/mailman/listinfo/mondrian
> 
> 
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20081002/60e92a84/attachment.html 


More information about the Mondrian mailing list