[Mondrian] [Fwd: Eigenbase perforce change 10569 for review]

Julian Hyde jhyde at pentaho.org
Tue Mar 25 18:27:58 EDT 2008


> John Sichi wrote:
>
> I thought the rule was that nowadays we HAVE to build with 
> JDK 1.6, but 
> as of the change below, we CAN'T build with JDK 1.6 (directly)?

I have to use JDK 1.5 to build a release. Otherwise the class files are not
compatible for folks that want to run mondrian.jar using JDK 1.5. So, the
'release', 'jar', 'binzip' targets all complain if you don't run under JDK
1.5.

However, I don't want to prevent developers running using JDK 1.6. I think
'ant compile' still works on JDK 1.5. I guess we could make 'ant jar' run
under JDK 1.5 too. 'binzip' and 'release' should still require 1.5.

If you agree, go ahead and make those changes to build.xml.

Julian

PS And by the way, the olap4j build works the same way.




More information about the Mondrian mailing list