[Mondrian] I need help conecting to Teradata

Julian Hyde jhyde at pentaho.org
Thu Feb 14 12:12:15 EST 2008


Two errors here. First, it can't find the object. Have you maybe spelled the
table in lowercase in your schema file, and it is uppercase in Teradata; or
perhaps it needs to be qualified by a schema name in teradata. Turn on SQL
tracing (mondrian.trace.level=1) and see what SQL mondrian generates, then
try running that SQL using teradata's command line.
 
Second, when you changed the schema.xml file you made it into invalid XML. I
think you forgot to terminate the <Level> element with />. Maybe you tried
to put comments inside the Level element?
 
Julian


  _____  

From: mondrian-bounces at pentaho.org [mailto:mondrian-bounces at pentaho.org] On
Behalf Of Francisco Martín
Sent: Thursday, February 14, 2008 4:48 AM
To: mondrian at pentaho.org
Subject: [Mondrian] I need help conecting to Teradata


Hello, I've been using Mondrn with Pentaho BI Suite and for some reason I
can't connect to Teradata with Mondrian, I can make reports using my DB, the
problem only comes with Mondrian. Here's what I do:
 
I use Cube Designer to design and publish a cube, at this point I have no
problem accesing the data from Teradata, I can use the graphic interface
perfectly. In Cube designer I have to use the JDBC drivers version
03.01.00.102, If I use newer ones I can't connect... So far so good
 
Now to actually SEE the cube, The JDBC drivers defined in Jboss are version
12.0, here the version 3.01.00.102 simply don't work. So, I go to
localhost/samples/analysis and when I click on a SampleData cube I can see
it perfectly, but, a Teradatya cube... NOTHING, The only thing I see is the
message from Jboss that goes like this:
 

10:23:15,865 INFO  [STDOUT] , exec+fetch 47 ms, 0 rows
10:23:15,865 ERROR [MondrianModel] Parse Failure
mondrian.olap.MondrianException: Mondrian Error:Failed to parse query '
         select NON EMPTY {[Measures].[SUM of
TBL_CUBO_CLIENTES_MCL_3000.RUTCLI]} ON columns, NON EMPTY {([Sexo.Sexo].[All
sexo], [Rango.Rango].[All r
ango])} ON rows from [cubo0902]
'
        at
mondrian.resource.MondrianResource$_Def0.ex(MondrianResource.java:755)
.
.
.
.
        at java.lang.Thread.run(Thread.java:595)
Caused by: mondrian.olap.MondrianException: Mondrian Error:Error while
parsing MDX statement '
         select NON EMPTY {[Measures].[SUM of
TBL_CUBO_CLIENTES_MCL_3000.RUTCLI]} ON columns, NON EMPTY {([Sexo.Sexo].[All
sexo], [Rango.Rango].[All r
ango])} ON rows from [cubo0902]
'
        at
mondrian.resource.MondrianResource$_Def0.ex(MondrianResource.java:755)
.
.
.
.
10:23:15,865 ERROR [MondrianModel] [NCR] [Teradata DBMS] : Object
'TBL_CUBO_CLIENTES_MCL_3000' does not exist.
10:23:15,865 ERROR [OlapModelProxy]
com.tonbeller.jpivot.olap.model.OlapException: [NCR] [Teradata DBMS] :
Object 'TBL_CUBO_CLIENTES_MCL_3000' does not exist.
 

(...And a lot more)
Which seems to be because the name of the Database itself is nowehre to be
found, it just references the tables. So, my natural instinct suggest me to
change the .xml and add the reference to the table... at this point I get
the following error:
 


10:27:51,940 ERROR [Logger] Error: Pentaho Pentaho BI Platform 1.6.0.GA.863
10:27:51,940 ERROR [Logger]
misc-org.pentaho.data.connection.mdx.MDXConnection: MDXConnection.ERROR_0002
- "Unable to create a native connection for c
onnection string: "Mondrian Error:Internal error: while parsing catalog
solution:samples/analysis/cuboprueba.mondrian.xml"
mondrian.olap.MondrianException: Mondrian Error:Internal error: while
parsing catalog solution:samples/analysis/cuboprueba.mondrian.xml
        at
mondrian.resource.MondrianResource$_Def0.ex(MondrianResource.java:755)
.
.
.

        at java.lang.Thread.run(Thread.java:595)
Caused by: org.eigenbase.xom.XOMException: Document parse failed: [Fatal
Error] :32:88: Element type "Level" must be followed by either attribute
spec
ifications, ">" or "/>".

        at org.eigenbase.xom.wrappers.GenericDOMParser.handleErrors(Unknown
Source)
        at org.eigenbase.xom.wrappers.JaxpDOMParser.parseInputSource(Unknown
Source)
        at org.eigenbase.xom.wrappers.GenericDOMParser.parse(Unknown Source)
        at mondrian.rolap.RolapSchema.load(RolapSchema.java:303)
        ... 94 more
10:27:51,956 ERROR [Logger] Error end:
10:27:51,956 ERROR [Logger] misc-MondrianModelComponent:
MondrianModel.ERROR_0001 - [es_82] getInitialQuery(): Connection is not
valid: {PoolNeeded=fa
lse, dataSource=java:TeradataDS, Provider=mondrian,
Catalog=solution:samples/analysis/cuboprueba.mondrian.xml}
10:27:51,956 ERROR [PivotViewComponent] Error Start: Pentaho Pentaho BI
Platform 1.6.0.GA.863
10:27:51,956 ERROR [PivotViewComponent]
79ff1a2b-da37-11dc-ad54-931a72ea8013:COMPONENT:context-17354178-120290927190
9:cuboprueba.xactionBase.ERROR_000
2 - Ejecuci¾n fallida del Componente
java.lang.NullPointerException
        at java.util.regex.Matcher.getTextLength(Matcher.java:1127)

.

.

.

10:27:51,956 ERROR [PivotViewComponent] Error end:
10:27:51,956 ERROR [RuntimeContext]
79ff1a2b-da37-11dc-ad54-931a72ea8013:RUNTIME:context-17354178-1202909271909:
cuboprueba.xaction RuntimeContext.ERRO
R_0012 - [es_33] ActionDefinition for PivotViewComponent did not execute
successfully

 
(Again, the error itself is a lot longer, but that seems like the most
important part)
PLEASE, at this point Im desesperate, I've searched every forum I've found
and I found nothing to help me, We have a lot of hope in this platform, but
at this point it's begining to be a lot of trouble. HELP!!
 
Thanks.
   Francisco Martín C.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20080214/a16cf8d4/attachment.html 


More information about the Mondrian mailing list