[Mondrian] re: roles and multiple hierarchies.. androllupPolicy="partial"

Ati Rosselet ati.rosselet at gmail.com
Fri Dec 12 19:36:13 EST 2008


Could very well be... the empty list part sounds familiar, and the use of
the "partial" rollupPolicy seems to be central here as well...  I guess we
stick to "full" (and try to geek an explanation to the users... :))
Thnx.
Ati

On Sat, Dec 13, 2008 at 1:27 AM, Julian Hyde <jhyde at pentaho.com> wrote:

>  Could it be this issue: http://jira.pentaho.com/browse/BISERVER-2491 ?
>
> Julian
>
>  ------------------------------
> *From:* mondrian-bounces at pentaho.org [mailto:mondrian-bounces at pentaho.org]
> *On Behalf Of *Ati Rosselet
> *Sent:* Friday, December 12, 2008 4:17 PM
> *To:* mondrian at pentaho.org
> *Subject:* [Mondrian] re: roles and multiple hierarchies..
> androllupPolicy="partial"
>
> Using jpivot, we have some strange behavior with roles...
> Without Role restrictions, each dimension with multiple hierarchies
> displays all the members of each hierarchy as expected... and one can select
> from any hierarchy (with a single hierarchy of course). Now.. if I apply a
> Role, interesting things happen.
> using rollupPolicy="partial", categories with partial visibility (other
> than the default hierarchy) are not appearing. If I remove the rollupPolicy
> statement, they appear. From what I can see.. JPivot is not getting the data
> to display the hierarchy.. so I'm assuming somehow that mondiran is
> removing/altering something in the Heirarchies returned with the query
> Results.... Any ideas? Julian?
>
> Second interesting effect. If we do not specify rollupPolicy on any of the
> hierarchy restrictions .. it/they appear (all are shown) and all works fine
> (with roles). If however, ANY hierarchies of a dimension have a
> rollupPolicy="partial" defined, thenafter selecting the other hierarchy and
> executing a query.. the other hierarchy returned is empty.... but can be
> accessed by writing it into the MDX query... so...
>
> So.. it seems that something is off with the rollupPolicy. Is this a
> known/experienced BUG? or a "feature" .. or.... I'll look at the source..
> but have no idea whether I'll get anywhere (the partial rollup policy would
> be very useful if it worked....)  I tried debugging into the guts of
> mondrian... but I can't see where the hierarchy members are disappearing (I
> assume it has something to do with the substutionMemberReader... maybe? :))
>
> Cheers
> Ati
>
>
> _______________________________________________
> Mondrian mailing list
> Mondrian at pentaho.org
> http://lists.pentaho.org/mailman/listinfo/mondrian
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20081213/17640c4b/attachment.html 


More information about the Mondrian mailing list