[Mondrian] Testing vs. retroweaver and 1.4

Eric McDermid mcdermid at stonecreek.com
Sun Dec 7 12:38:46 EST 2008


So as it turns out, ReentrantReadWriteLock is not supported in  
retroweaver 1.2.4, which is what mondrian is currently using.  It is,  
however, supported as of retroweaver 2.0.1, released on Sept. 30, 2007  
(this release fixed the bug that blocked Tushar from doing the same  
thing way back in April 2007).

The current version of retroweaver is 2.0.7, released Oct. 14, 2008,  
and also includes a much more recent (and more comprehensive) version  
of the concurrent backport.

Assuming I can get all tests to pass, is there any reason not to  
upgrade mondrian to the latest version of retroweaver?

  -- Eric




More information about the Mondrian mailing list