[Mondrian] testItemNull() test failure

Julian Hyde julianhyde at speakeasy.net
Tue Jun 26 16:51:57 EDT 2007


I fixed it.
 
The whole expression yields a member, I think [Store].[All stores],
which is then evaluated to a scalar. What that scalar evaluates to
depends on the context of all dimensions except [Store]. Because of the
Item() function, the dimensionality of that member was null, and the
dependency checking was converting 'depends on unknown dimension' into
'does not depend on any dimension'. 
 
Julian


  _____  

From: mondrian-bounces at pentaho.org [mailto:mondrian-bounces at pentaho.org]
On Behalf Of Thiyagu Palanisamy
Sent: Tuesday, June 26, 2007 2:22 AM
To: julianhyde at speakeasy.net
Cc: mondrian at pentaho.org
Subject: [Mondrian] testItemNull() test failure



Hi Julian, 

 We tried to address the testItemNull() test failure. We investigated on
what is going wrong with dependency check for Filter([Store].Members,
(0.0 = 0.0)).Item(0.0).Item(0.0). It finally reaches '0.0' to evaluate
if a dimension is depend on it. Since it is constant calc it returns
that is it not dependent on any dimension.   

 Our test is to validate that we are not getting null pointer exception
any more. Since we are not that familiar with dependency checks we are
inclined to opt for a simple change in the test like "0 *
(Filter([Store].members, 0 = 0).Item(0).Item(0), Filter([Store].members,
0 = 0).Item(0).Item(0))" which will always pass the dependency check and
also ensures our null pointer fix is in place. 

 Please let us know how should we take this forward. 

Thanks, 
Thiyagu & Shishir 
  
  


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.pentaho.org/pipermail/mondrian/attachments/20070626/fe037d50/attachment.html 


More information about the Mondrian mailing list