[Mondrian] Re: VirtualCubeTest.testCalculatedMemberAcrossCubes failing on SMP

John V. Sichi jsichi at gmail.com
Mon Jan 22 14:10:24 EST 2007

Something interesting:  I noticed that HotSpot was automatically 
selecting Server mode on the SMP machine (whereas on my laptop it 
autoselects Client mode).  I changed build.xml to force usage of Client 
mode, and then "ant test" ran through with no failures.

Haven't tried forcing Server mode on laptop yet; if it's timing-related, 
it may just be that it takes the combination of a very fast machine plus 
Server mode to hit it.

Also, Bart, if you want to send me code modifications to enable tracing 
targeted at debugging the problem, please do, and I'll run it through on 
the SMP machine and send you the output.


John V. Sichi wrote:
> Pappyn Bart wrote:
>> John,
>> Could you tell me what kind of OS is running on your
>> 4-way SMP machine ?  And on you laptop ?
> SMP:  Red Hat Enterprise Linux (not sure of version); JVM is HotSpot 
> 1.5.0_10-b03
> Laptop:  Edgy Eft version of Ubuntu Linux; JVM is HotSpot 1.5.0_04-b05
> My guess is that it's likely to be a timing-sensitive thing.  The 
> property trigger stuff looked suspicious, but I tried disabling that out 
> and it still happens.  I also tried disabling 
> testFormatStringExpressionCubeNoCache (since it runs just before and has 
> cache disabled on a base cube underlying a virtual cube) but the failure 
> still occurred.

More information about the Mondrian mailing list